Data Sources

Datasources

bipp supports a wide range of databases you can use as datasources. All datasources are managed from bipp. Refer to the individual database topics for connection details.

Email bipp if you find problems or have updates for the database connection information. Your help is appreciated!

Managing Datasources

Select Develop > Datasources from the Home Navigation pane to open the Datasources page.

Datasource Page

Here are the available datasource controls:

  • New Datasource opens the New Datasource dialog.
  • Search displays the datasources matching your search string.
  • Delete deletes the selected datasources.
  • Options Menu displays the datasource Options menu.
    Options Menu
    • Run Query opens the SQL Editor for the datasource.
    • Ping sends a ping to the datasource to verify connectivity.
    • Edit opens the Edit dialog to change the datasource settings. You must re-enter the password.
    • Share opens the Share dialog to share your datasource.
    • Delete deletes the datasource.

Creating a New Datasource

  1. Click New Datasource on the Datasources page.

    New Datasource

  2. Enter a Name. For example, Retail.

  3. Select the Dialect for the SQL used for your database. bipp creates and enforces the rules for the selected dialect.

    Datasource Settings

  4. Enter the connection details and the credentials. The details are different for each dialect. The Connecting Databases section lists the supported databases and known connection details.

  5. Click Test to verify the datasource connectivity. If you have an error, fix the connection or credentials problem and click Test again. Here are sample messages:

    Test Test

  6. Click Create to add the datasource.

Searching for a Datasource

Enter all or part of a name in the Search box on the Datasources page to search the list of datasources. The matching datasources are displayed as you type.

Datasource Search

Editing a Datasource

You can edit an existing datasource to update the connection settings:

  1. Select Edit from the Options menu for your datasource and .
  2. Make your changes.
  3. Re-enter the Password for the datasource connection.
  4. Click Update.
  5. Verify the connectivity with the Ping command.

Pinging a Datasource

You can ping a datasource to verify connectivity:

Select Ping from the Options menu for your datasource.

If Ping succeeds, your datasource is ready to go.
Pings
Pings
If you have an error, select Edit from the *(Options menu and fix the connection or credentials problem. Remember to re-enter the Password in the Edit dialog.

Sharing a Datasource

You can share your datasources with bipp users in your team, organization or network.

  1. Select Share from the Options menu Roles command for your datasource.

    Datasource Groups

  2. Enter the name or email of the user.

  3. Select a Role.

    Datasource Roles

  • Owner can query, edit, share and delete the datasource.

  • Admin can query, edit and share the datasource.

  • Explorer can query the datasource.

  1. Click Share.

Deleting a Datasource

The Owner and Admin roles can delete a datasource. There are two methods:

  • Select one or more datasources on the Datasources page and click Delete.
  • Select Delete from the Options menu for the datasource.

Click Delete on the confirmation prompt or Cancel to keep the datasource.

SQL Editor

Select Run a Query from the Options menu to explore the datasource. bipp opens the SQL Editor.

SQL Editor

Click anywhere outside the editor to close the window and return to the Datasources page.

Here are the available SQL Editor controls:

  • Datasource pane (left side) shows the name of the open datasource and an expandable tree view of the tables and columns in the datasource. You can collapse (⏴) or expand (⏵) the Datasource pane.

  • Query pane is where you write your query. bipp helps you with query shortcuts:

    • Keyword Completion: As you type in the editor, bipp provides the relevant commands to assist you in creating your query. You can enter enough unique characters and use Tab or select it from the list with the mouse.
      Keyword Complete
    • Select *: Click the arrow beside a table to automatically generate the SELECT * statement for a table. Here is the result when you click the arrow beside stocks:
      Auto Select \*
    • Select column: Click the column name to insert the column name. Here is the result when you highlight the * expand stocks and click code:
      Auto Select \*
  • Results pane is where results are displayed. You can view your results as Data or as a Chart. Use the display icon by the SQL Editor heading to switch between displaying the Query and Results panes side by side or top and bottom. (Query Editor Vertical Query Editor Horizontal)

  • Run runs the query and displays the results in the selected Results pane.
  • Options Menu displays the Query Editor Options menu.
    Options Menu
  • Download Data downloads the results of your query as an Excel file (.xlsx). This is a Premium feature.
  • Total rows is the number of rows returned in the Results pane.
  • Time (sec) is the time in seconds to execute the query.

Viewing Results: Data

When you are ready, click Run. Here is an example on the Data tab in the Results pane:

SQL Editor Data Results

Viewing Results: Chart

Click Chart to switch to the chart view of your results. The default view is a Bar chart.

SQL Editor Chart Results

Hover over a bar to see the details:

SQL Editor Chart hover

Adjust the sliders to focus the chart:

SQL Editor Chart focus

Select different chart types from the drop down:

SQL Editor Chart focus

Editing the Chart

Click the Edit icon Edit icon

The Chart Editor gives you full control over your data visualization.

Chart Editor

Here are the Chart Editor controls:

  • Chart type selection icons. The current type is highlighted.
  • Chart settings Chart settings
  • Data Settings. You can collapse (⏴) or expand (⏵) the Settings pane.
  • Cancel discards your changes and returns to the SQL Editor results.
  • Save Saves the settings.